网站建设

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

Jager · 1月12日 · 2015年 · · · 5790次已读

上一篇文章《PHP跨站脚本攻击(XSS)漏洞修复方法(一)》写到了360修复XSS漏洞的插件并不完善的问题,那么这篇文章就来分享一下自己如何写代码修补这个漏洞。

从上一篇文章看出,部署了360出的XSS修复插件之后,至少还存在iframe无法过滤缺憾,是否还有其他纰漏目前还不得而知。

分析一下中国博客联盟和张戈博客已开放的数据入口:

①、中国博客联盟,主要有搜索、后台博客提交等;

②、张戈博客(WordPress),主要是用户评论提交;

所以,本文就已这2个入口为例子,来分享XSS漏洞修复的简单思路。

一、完全过滤

问题①,我可以找到站内搜索和博客提交这2个开放入口的数据处理php,然后对数据过滤即可。

比如站内搜索,中国博客联盟取得搜索关键词是这样一行代码:

$keyword = addslashes(trim($_GET['query']));

考虑到中国博客联盟的站内搜索,只能搜索博客名称、域名、类型及描述这四种,而这四种均不需要出现html代码!如果有人提交搜索了html代码,绝非善意!

那对于这种情况,我只需要完全过滤掉html内容即可!所以可以用到strip_tags()函数,具体运用如下:

$keyword = strip_tags(addslashes(trim($_GET['query'])));

在数据外套上 strip_tags 进行html完全过滤即可!那么系统后台得到的数据就是不含任何html代码的。

比如,依然搜索360爆出的“88888<iframe src=http://xxooxxoo.js>”:

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

从搜索结果可以看出,系统已自动过滤了后面的iframe恶意内容,问题得到解决。

因此,对于XSS漏洞的第一种修复方法就是使用 strip_tags 函数来完全过滤html内容。

二、代码转义

问题②,WordPress的评论并不能如此暴力的过滤,因为很多用户确实是想提交一些html代码,来进行交流。

对于这种情况,有3种思路:

以下三种方法中,选择你所中意的一种方式,添加到主题functions.php里面即可:

A. 直接过滤,允许提交

add_filter('comment_text', 'filter_comment');
function filter_comment($comment_content) {
    if ( '' != $comment_content ) {
        /* $filter 是需要过滤的关键词,关键词之间用分隔符 | 隔开即可。 */
        $filter = '/<(iframe|script)/i';
        if (preg_match($filter,$comment_content,$matches)) {
            $comment_content = strip_tags($comment_content);
        }
    }
    return $comment_content;
}

效果截图:

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

B. 提出警告,禁止提交

add_filter('comment_text', 'filter_comment');
function filter_comment($comment_content) {
    if ( '' != $comment_content ) {
        /* $filter 是需要过滤的关键词,关键词之间用分隔符 | 隔开即可。 */
        $filter = '/<(iframe|script)/i';
        if (preg_match($filter,$comment_content,$matches)) {
            wp_die('警告:评论含有危险内容,已被拦截,请在更正后重试。'); 
        }
    }
    return $comment_content;
}

效果截图:

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

C. 内容转义,允许提交

add_filter('comment_text', 'filter_comment');
function filter_comment($comment_content) {
    if ( '' != $comment_content ) {
        /* $filter 是需要过滤的关键词,关键词之间用分隔符 | 隔开即可。 */
        $filter = '/<(iframe|script)/i';
        if (preg_match($filter,$comment_content,$matches)) {
            $comment_content = htmlspecialchars($comment_content).'<br />(<font color="red">系统提示:评论含危险内容,已被转义处理。</font>)';
         }
    }
    return $comment_content;
}

效果截图:

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

其中过滤列表只写了iframe和script2种,如果你需要过滤其他你不喜欢的内容,比如某些人评论总是带上链接,这些都是可以过滤的!反正方法我已经分享了,具体就看你自行发挥了!

Ps:其实WordPress本身已屏蔽了XSS漏洞,评论是不允许一些html代码的, 比如font字体标签等。本文也只是为了探讨修复XSS漏洞的一个简单思路,临时关闭了HTML过滤。为了安全起见,非特殊情况,还是不要禁止WordPress自带的HTML过滤为好!

最后,再去用360扫一扫,已经是“满意100”了:

PHP跨站脚本攻击(XSS)漏洞修复思路(二)

好了,关于XSS漏洞的简单修复思路的探讨,就暂告一段落,后续有新的见解再来补充完善。

8 条回应
  1. 小武 2015-1-12 · 12:44

    嗯. 最安全的就是 只要遇到尖括号 就转义. .

  2. 必分享 2015-1-12 · 21:52

    支持下。

  3. 消灭星星 2015-1-20 · 22:33

    🙁 🙁 🙁 签到成功!签到时间:下午10:32:43,每日签到,生活更精彩哦~

  4. zhangsan 2015-4-2 · 21:25

    <script>alert(“XSS测试”)</script>

  5. kid 2016-12-12 · 18:31

    测试一下

  6. kid 2016-12-12 · 18:33

    大神你好,露兜这种转义方法还有用吗 http://www.ludou.org/wordpress-escape-comments.html

  7. kid 2016-12-12 · 18:34

    777 在测试一下

  8. Panda 2019-7-15 · 11:46